[CentOS]使用remi的repo,安裝/更新PHP 7.3

CentOS預設的PHP版本就算上了EPEL也一樣是5.4.16,所以需要remi這套CentOS官方認可的軟體庫來做更新的動作,但一定要特別注意也許可能會造成會有某些套件的衝突,下方的紀錄是我安裝過測試過的,暫時還沒發現什麼問題 🤖🤓🤖

步驟1. 備份原先phpMyAdmin、Roundcube的檔案

步驟2. 安裝EPEL和remi的repo

步驟3. 安裝YUM的附加套件,並且啟用remi-php73的功能,然後停用其他舊版本PHP的支援

步驟4. 停止Apache並且移除原先的PHP和其他PHP套件,請注意最後一句的php70-php需要依照原先安裝的版本(如php71-php或php72-php)做調整,沒有就不用

步驟5. 安裝最新的PHP 7.3

步驟6. 將PHP 7.3設定成預設呼叫

這時候應該會看到已經安裝成功了

步驟7. 微調php.ini,放寬上傳檔案的限制

先使用此指令查詢設定檔位置

然後輸入下列指令,如果設定檔不是在/etc/opt/remi/php73/php.ini就需要自行更改設定檔位置

步驟8. 還原phpMyAdmin、Roundcube的檔案
步驟9. 重啟Apache

PS: remi提供的PHP 7.3的附加套件如下,可自由選配

關於 窮苦人家的小孩

In every democracy, the people get the government they deserve. ~Alexis de Tocqueville

您可能會喜歡

希志あい 希志愛野 Kishi Aino

Oracle Linux 8初始化環境設定

2020年底的大爆炸消息就是C …